Advertisement


Why am I unable to move pixels after they have been selected?


Question

I've selected the below area in my image. I then switch to the move tool, but when I drag around the selection, the pixels that it had encompassed do not move with it. Would be great to know what I'm doing wrong :)

Thank you in advance.

enter image description here

2013/06/20
1
1
6/20/2013 5:21:00 PM

The Rectangular Marquee Tool (M) strictly selects and area. With the Marquee tool still selected, clicking and dragging will move the marquee around without influencing any pixels.

If you want to move the selected pixels with the selection you must make sure you have the Move Tool (V) selected. Then simply click-and-drag the area around to move the selected pixels.

If for some reason the area still won't move it may be because you do not have the proper layer selected or perhaps you have multiple layers selected. Also ensure that your layer is not a text-based or smart object layer.

EDIT

In reply to your comment:

That is correct. You cannot move the selected pixels across multiple layers much like you can't paint on multiple layers simultaneously. Your alternatives would be to merge your layers (I'd back-up my non-merged layers first). Another method is you make your selection then go to Select > Save Selection.... Once your selection is saved you can use it to move one layer, then you may load the selection by going to Select > Load Selection... and then moving the other layer, etc.

I'm not familiar with other methods, though there may be other ones. It may also be possible to write a custom script that allows dragging selections across multiple layers.

2013/06/21
4
6/21/2013 3:40:00 PM